Visa service disruption
Incident Report for Flipdish
Resolved
Visa transactions appear to have returned to normal.
Posted about 1 year ago. Jun 01, 2018 - 21:42 BST
Identified
Hi there,

Visa is currently experiencing a service disruption resulting in a higher rate of declines on European cards. This began at 13:35 UTC on June 1st and is ongoing. We wanted to make sure you were aware. We are continuing to monitor the situation and will keep you apprised of status changes as they occur.

Follow along Visa’s latest status here:
https://twitter.com/VisaNewsEurope
Posted about 1 year ago. Jun 01, 2018 - 18:46 BST