Slow performance on some Flipdish hosted websites
Incident Report for Flipdish
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 18:44 GMT
Investigating
We are currently investigating an issue with some slow performance of our Flipdish hosted websites. This is ongoing and the team are engaged in solving this issue for our customers.
Posted Nov 15, 2022 - 16:45 GMT