Printers: Goodcom Printer issues
Incident Report for Flipdish
Resolved
This incident has been resolved.
Posted Feb 10, 2023 - 11:42 GMT
Investigating
We are aware of some intermittent issues with Goodcom printers and are in contact with our SIM provider to investigate. Many printers have been restored to working order by restarting them.
Thanks for your patience as we work towards a resolution. Please contact support if you have any further queries or concerns.
Posted Feb 02, 2023 - 17:12 GMT
This incident affected: Secondary services (unlikely to affect receiving orders) (SIM Printers).