Support phone system outage
Incident Report for Flipdish
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 07, 2019 - 07:31 BST
Investigating
We are currently investigating the issue
Posted 4 months ago. Jun 06, 2019 - 18:32 BST